TensorFlow <2.3>=2.0 states NumPy<2.0.0 as a dependency, but is compatible with NumPy<1.19.0

NumPy in versions >=1.19.0<2.0.0 has a breaking ABI change making it incompatible with TensorFlow in versions <2.3>=2.0.

Issue description

TensorFlow releases matching version range specification <2.3>=2.0 stated NumPy<2.0.0 as a dependency. A new release 1.19.0 of NumPy introduced a breaking change which made the version range specification of TensorFlow not valid for a more recent NumPy releases.

Affected packages:

Severity

Issue fix

The recommendation engine will try to resolve a software stack with a compatible NumPy release without ABI breaking change.

Pipeline units

Recommendation types

All the recommendation types can produce this warning message, except for latest:

See this document that describes recommendation types listed.

Issues associated