TensorFlow in version 1.13.1 is compatible with NumPy>=1.16.0

TensorFlow in version 1.13.1 depends on numpy>=1.13.3 but is compatible only with numpy>=1.16.0.

Issue description

TensorFlow in version 1.13.1 has wrong requirement on numpy>=1.13.1. It is compatible only with numpy>=1.16.0.

In [1]: import tensorflow
---------------------------------------------------------------------------
ModuleNotFoundError                       Traceback (most recent call last)
ModuleNotFoundError: No module named 'numpy.core._multiarray_umath'
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
ImportError: numpy.core.multiarray failed to import

The above exception was the direct cause of the following exception:

SystemError                               Traceback (most recent call last)
~/anaconda3/envs/w4/lib/python3.6/importlib/_bootstrap.py in _find_and_load(name, import_)

SystemError: <class '_frozen_importlib._ModuleLockManager'> returned a result with an error set
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
ImportError: numpy.core._multiarray_umath failed to import
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
ImportError: numpy.core.umath failed to import
2020-09-20 10:41:12.458915: F tensorflow/python/lib/core/bfloat16.cc:675] Check failed: PyBfloat16_Type.tp_base != nullptr

Affected packages:

Severity

Issue fix

The resolution process will try to come up with an alternative NumPy that will satisfy compatible NumPy release.

Pipeline units

Recommendation types

This warning can be produced for all the recommendation types, except for latest:

See this document that describes recommendation types listed.

Issues associated